29 lines
1.3 KiB
Bash
29 lines
1.3 KiB
Bash
# Maintainer: Jonathan Apodaca <jrapodaca@gmail.com>
|
|
|
|
pkgname=lazygit-bin
|
|
pkgver=0.50.0
|
|
pkgrel=1
|
|
pkgdesc='A simple terminal UI for git commands, written in Go with the gocui library'
|
|
url="https://github.com/jesseduffield/lazygit"
|
|
license=('MIT')
|
|
provides=("lazygit")
|
|
conflicts=("lazygit")
|
|
arch=('aarch64' 'arm64' 'armv6h' 'i686' 'amd64')
|
|
extensions=('zipman')
|
|
|
|
source_aarch64=("${url}/releases/download/v${pkgver}/lazygit_${pkgver}_Linux_arm64.tar.gz")
|
|
source_arm64=("${url}/releases/download/v${pkgver}/lazygit_${pkgver}_Linux_arm64.tar.gz")
|
|
source_armv6h=("${url}/releases/download/v${pkgver}/lazygit_${pkgver}_Linux_armv6.tar.gz")
|
|
source_i686=("${url}/releases/download/v${pkgver}/lazygit_${pkgver}_Linux_32-bit.tar.gz")
|
|
source_amd64=("${url}/releases/download/v${pkgver}/lazygit_${pkgver}_Linux_x86_64.tar.gz")
|
|
|
|
sha256sums_aarch64=('3f5728d99263ae2055ce7f767d60e75fef4faf14b5a5511281108d91b1dff624')
|
|
sha256sums_arm64=('3f5728d99263ae2055ce7f767d60e75fef4faf14b5a5511281108d91b1dff624')
|
|
sha256sums_armv6h=('00021f090bdb792dde111c61a048a33224e79bc865f469e248d3f7a0c5a0ade3')
|
|
sha256sums_i686=('c02d153dd32d7877c0317f5dad74be75325149104706979bca3879f85b6bf831')
|
|
sha256sums_amd64=('bb2bc0ac8b1e2678c650c5aa8a6fa1595e46f8825ce7e6a3833ca95768179881')
|
|
|
|
package() {
|
|
install -Dm755 "${srcdir}/lazygit" "${pkgdir}/usr/bin/lazygit"
|
|
}
|